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Designing a dashboard

This chapter contains the following topics:
m About dashboard applications

m Planning dashboard layout

m Creating a dashboard

m Adding gadgets to a dashboard
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About dashboard applications

A dashboard is a self-contained web application which delivers business
performance data in interactive charts, cross tab tables, BIRT documents and
external web services. Dashboards are quickly built using gadgets that display
data driven visualizations, files, or enable user choices. These gadgets can link
together to display data related to user requests, as shown in Figure 1-1.
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Figure 1-1 Displaying a sample dashboard layout

When you build a dashboard you add gadgets to one or more tab pages of a
dashboard, similar to web pages. You choose the content to display in each
gadget and users of the dashboard can interact with that content, such as a chart
or table of data. The following gadget types are available:

m  Report gadgets display BIRT content such as BIRT documents, libraries, and
user input parameters from BIRT documents.

m Chart gadgets organize and display data using symbols such as bars and lines.

m Table gadgets display data values in cross tabs and in a row and column
format.

2 Designing BIRT Dashboards



m Data selector gadgets show values for users to query data in other gadgets.

m Extras gadgets display external content such as web applications, video,
HTML, JavaScript code, and Google gadgets.

You can create dashboards using the BIRT Designer Professional desktop
application. Finished dashboards are deployed to a BIRT iHub or cloud server,
such as BIRT onDemand and available to users in the following formats:

m A dashboard file in Visualization Platform
m A URL address when deployed as a BIRT application
m A web page using Actuate JavaScript API (JSAPI) to embed the dashboard

Users can then interact with, export, or print data displayed in existing
dashboards or include your published dashboard as a page in their own
dashboard file when using Visualization Platform.

Planning dashboard layout

Planning dashboard usage assures that users receive and interact with the
expected data. After choosing the content and data to display on the dashboard
select the gadgets to display this information. Verify that user permissions, such
as file permissions necessary to view BIRT documents or BIRT data objects,
enable target users to access this information. Then consider how you want users
to interact with these gadgets. For example, do you filter the displayed data for
the user or do you enable users to select filter values with data selection gadgets.

Finally, determine the dashboard layout for the expected web browser and screen
size. Each dashboard supports four different layout formats; one column, two
column, three column and free form. You can change gadget placement on the
dashboard to find the best balance of presentation and interaction. For example,
keep related user interaction gadgets together. Users can also view any gadget,
except the data selection gadgets at full screen.

Creating a dashboard

You create a new dashboard file using the dashboard editor in BIRT Designer
Professional. These files are stored in the project folder. If you plan to display
charts verify that your BIRT data object file exists in the project.

How to create a new dashboard

1 In BIRT Designer Professional choose File>New->Dashboard.
New Dashboard appears as shown in Figure 1-2.
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Dashboard

Create a new Dashboard,

Enter or select the parent Folder:
¥ Use Default Location

| [BIRT ProjectfDashboards

fir - =

E-{5] BIRT Project

File name: | new_dashboard.dashboard

® Cancel |
Figure 1-2 Displaying the dashboard editor

2 The current project and the default folder for dashboards is selected.

» If you want to use a different project or folder to store the dashboard file,
remove the selection Use Default Location to access the tree view of the

available folders.

m If you want to change the dashboard file name, type the new name in File

name.

3 Choose Finish. The dashboard editor appears, as shown in Figure 1-3.

=10] |
File Edit View Layout Insert Data Help new_dashboard
= WS O MNERBENEPE @16 S/ 0
New Tab 1 Hide
Figure 1-3 Displaying the dashboard editor

4 Choose Save to save the new dashboard file to the project.
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Adding a dashboard tab

A dashboard is divided into one or more pages called tabs. These tab pages
enable you to organize the gadgets. For example, one tab page contains gadgets
necessary to make a new customer order and another tab page can contain
gadgets displaying a customer’s order history. You can name each tab page to
identify its contents and change the order that the tab appears in relation to other
tabs.

How to add a dashboard tab

1 In the dashboard editor, choose Edit>New Tab to create an empty, new tab
page.
2 Choose Edit>~Rename Tab to change the tab name.

Choosing a dashboard layout

Dashboard layout defines how gadgets appear on a dashboard. Each gadget uses
either a column or free form layout. Gadgets in column layouts do not overlap
and appear either above or below another gadget in the same column. You can
place gadgets in free form layout anywhere on the dashboard. If a free form
gadget overlaps another gadget, the user can move the gadget to the front or back
of the other gadgets.

Dashboards support a one-, two-, or three-column layout in addition to a free
form layout. You can use the columns to organize gadgets on the dashboard.
Dashboard columns are a percentage of the user’s web browser size. If the web
browser changes size, the dashboard columns are resized. Gadgets in a resized
column also resize to match the new width of the column.

Choose the free form layout if you need to move or resize gadgets anywhere on
the dashboard. Free form layout supports overlapping gadgets and changing the
width of individual gadgets.

For example, a single-column dashboard expands to fill the width of the web
browser, and the gadgets in the column are resized accordingly. Floating gadgets,
such as gadgets in a free form layout, do not change their width or location on the
dashboard when the browser size changes.

For complex visualization layout, use BIRT design features available in BIRT
Designer Professional. For example, use BIRT Designer Professional to put
multiple charts into a grid element or cross tab container. You can display the
finished BIRT design file on a dashboard using a report gadget.

How to change a dashboard layout

In the dashboard editor, choose Layout>Two Columns, as shown in Figure 1-4.
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Figure 1-4 Configuring gadget layout in columns and free form

How to resize a column in a dashboard
This example begins with a dashboard that uses a two-column layout.

1 In the dashboard editor, hover the mouse pointer over the vertical space
between two gadgets, as shown in Figure 1-5. The column bar appears.

New Tab 1 Hide
Text Gadget 1 Text Gadget 2
Sample Text Sample Text
Column bar
Figure 1-5 Resizing a column in a dashboard

2 Drag the bar to the left, to a new location, as shown in Figure 1-6.

New Tab 1 Hide

Text Gadget 1 Text Gadget 2
Sample Text Sample Text

Figure 1-6 Choosing a new column width in a dashboard

Existing gadgets are resized to fit within the new column widths.
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Formatting a dashboard tab

You can personalize the tab page of a dashboard with the following formatting
options:

Auto refresh, to refresh the dashboard at a selected interval
Background color, to set the background color of the dashboard page

Background image, to display an image as the background of the dashboard
page

Show Headers On, to show headers on selected gadgets

Show Tab Footer, to include HTML text at the bottom of the dashboard page
Show Tab Header, to include HTML text at the top of the dashboard page

Tab Name, to customize the name of the dashboard tab

For example, you can add a row of HTML hyperlinks to the top of your
dashboard or other HTML content with customized CSS styles inside the tab
header.

Activating auto refresh sets the dashboard to refresh at the selected interval. Data
and reports update at the selected interval. Set refresh settings to a speed that

your BIRT iHub supports. Each refresh requests an update for all content on the

dashboard tab page. Check with your BIRT iHub administrator for the supported
refresh frequency.

These formatting options are available from the dashboard editor when you
choose Edit>Options, as shown in Figure 1-7.

Tab Options

General

TabMame NewTab1
Show Tab Header
Show Tab Footer

Auto Refresh

(#) Background Color | Auto =
Background Image
Show Headers on ...

All Gadgets

Cancel m

Figure 1-7 Setting dashboard options
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Adding data objects to a dashboard

When you add a BIRT data object to a dashboard, all new gadgets added to that
dashboard can use the data object. This can save time when adding multiple
gadgets that use the same data object. If you add multiple data objects to a
dashboard, each time you add a new gadget, the data objects you have added
appear in the category Current Data Selection.

How to add a data object to a dashboard

1 In the dashboard editor, Choose Data>Manage Data to select data objects to
assign to the dashboard, as shown in Figure 1-8.

=10 x]

File Edit View Layout Insert Help new_dashboard m
= e w0 ol 5 = - o

New Tab 1 Hide

Figure 1-8 Displaying Opening Manage Data to add data objects

2 In Available Data, select a data object inside the project and choose the right
arrow. The selected data object appears in Selected Data, as shown in

Figure 1-9.
Manage Data Data
preview
Available Data: Selected Data: ¢(3— Refresh
< Prjectioot T D
» Dashboards & Datacubs H B, Orders.datadesign  On-Demand {} ObjeCt
version
» ReportDesigns
» ReportLibraries
» ReportTemplates
Data
object
Cancel m contents

Figure 1-9 Selecting a data object to use in a dashboard

If multiple versions of a BIRT data object are available, you can select which
version to use in the dashboard. You can browse the contents of a data object
to verify it contains the data you require.
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Importing an existing dashboard

You can add a shared dashboard file to a dashboard that you are editing. Choose
Insert>Dashboard From Gallery to import a dashboard file into your new
dashboard. This enables you to quickly add existing dashboards as new pages in
your own dashboard file.

Imported dashboards appear on your dashboard as tab pages with a share icon in
the tab title. You cannot edit the content of a shared dashboard. Dashboard tabs
with the shared icon link to the original dashboard file and changes to the original
dashboard file appear in the imported dashboard when it is refreshed. Figure 1-10
shows two imported tabs called Customers and Orders.

e Layout nsert Data Help new_dashboard m

= W = O E E E L A 0O

@
=
(]

Mew Tab 1 n » Hide

Figure 1-10 Importing dashboard tabs

To change the content of imported tab pages, either duplicate the tab pages or edit
the original dashboard file. Choose Edit>Duplicate Tab to copy the selected tab
into a new tab page. You can edit a copied tab page because it is no longer linked
to changes in the original dashboard file.

For example, you want to include an existing dashboard file in your new
dashboard but you want to also change the layout and replace a chart gadget
with a table gadget. After importing the existing dashboard, you then duplicate
it. A new tab page appears in your dashboard with the same content as the
imported dashboard. You can edit the duplicated tab page. Finally, you do not
need the imported tab page with the share icon and can delete it.

Saving a dashboard

Save changes to a dashboard by choosing File>Save. To save the dashboard with
a new name, choose File>Save as, navigate to a new location and give a new
name for the dashboard file, as shown in Figure 1-11.

When you save a dashboard file using BIRT Designer Professional, you save the
file to a folder in a BIRT project or a BIRT application. You can then deploy the
project or application to a BIRT iHub or cloud server, such as BIRT onDemand or
export the dashboard file.
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Save As
Qutput location: Browse...
Name Type
settings DIRECTORY
Dzzhboards DIRECTORY
Data Objects DIRECTORY
Report Designs DIRECTORY
Report Libraries DIRECTORY
Report Templates DIRECTORY
Name: new_dashboard.dashboard
conce | (KD
Figure 1-11 Saving a dashboard file to a new folder

Opening a dashboard file

You can open a dashboard file in a BIRT project or BIRT application using the
Navigator. Navigate to the folder containing the file and double-click the
dashboard file, as shown in Figure 1-12.

EE Qutline T Mavigator £3

E-5 BIRT Project
E| [ Dashboards
I new_dashboard.dashboard

= Data Objects

= Report Designs

= Repart Libraries

= Report Templates

H| .project

: =] BIRTApplication sml

e [2] indese bt

Figure 1-12 Navigating to a dashboard file

Dashboard files require additional files such as BIRT data objects and BIRT
documents. These files must exist where the dashboard file expects to find them.

If you need to send dashboard files for editing or review to someone that does not
have access to your iHub server, put the dashboard and its resources into a BIRT
application file. The recipient of the BIRT application file can then open the
dashboard in BIRT Designer Professional or their BIRT onDemand account to
view and edit the dashboard file.

Adding gadgets to a dashboard

Use the dashboard editor to add new or existing gadgets to the dashboard.
Choose Insert and select a gadget category, such as charts. Then choose the type
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of chart gadget, such as a bar chart. The gadget builder for the selected gadget
type appears for you to select content to display in the gadget.

If you have existing gadget files in your BIRT application folder, choose
Insert>Gadget Gallery to display the file browser and search for the gadget file to
add to the dashboard. After the gadget appears on the dashboard, you can place
it where you want and edit the gadget options to change the format and other
settings of the gadget. You can save dashboard gadgets as gadget files using
Visualization Platform.

Placing a gadget

New gadgets use the dashboard layout when added. You can move existing
gadgets on the dashboard to a different column or set the gadget to float when the
dashboard uses the column layout. You can place floating gadgets anywhere on
the dashboard while other gadgets remain in the column layout. Select Dock from
the gadget menu to return a floating gadget to the column layout of the
dashboard.

If the dashboard uses a column layout, you can move the gadgets above or below
other gadgets in the same column. Gadgets in a column layout do not overlap
and have an adjustable height. If the dashboard uses a free form layout, all
gadgets are floating. Floating gadgets have an adjustable height and width. When
the free form grid is displayed, you can snap gadgets to a grid for precise
placement. Figure 1-13 shows gadgets in a three-column layout with two floating
gadgets. Gadget 5 and gadget 6 are floating, in this example.

New Tab 1 Hide

extisadgetr4

4

Figure 1-13 Gadgets in a three-column layout with floating gadgets

How to add a new gadget to a dashboard

BIRT Designer Professional includes gadget templates to quickly add visual
content to your dashboard. Use BIRT iHub to create your own gadgets that you
can import into your project.
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1 In the dashboard editor, choose Insert>Extra>Text to open the gadget
builder, as shown in Figure 1-14.

=10 x|
File Edit View Layout Data Help new_dashboard m
- NN M ' ®m P S /4 O
[_§ E =/ -
ElTable.. »
New Tab1 [El Data Selector... 3 e
I!IRepDrt... >
le]Extra.. 4 HTML
Video
Current Selections
Image
Text
Edpashboard From Gallery...
Import Gadget
& Gadget from Gallery...

Figure 1-14 Adding a gadget to the dashboard

2 Complete the gadget configuration depending on the gadget you choose. This
example uses a text gadget. Choose OK when you are finished configuring the
gadget, as shown in as shown in Figure 1-15.

Mew Text Gadget

General Text Settings

HTML Editor: = |Blrull A AR ==
I I u =Y ==

Sample text

Ml
[
il
1]
m

Cancel m

Figure 1-15 Configuring a new gadget
The selected gadget appears on the dashboard.

How to change the size of a gadget

1 Hover the mouse pointer over the border of a gadget. A solid line appears,
highlighting the borders that you can modify, as shown in Figure 1-16.

Text Gadget 1

Sample Text

Mouse pointer

Figure 1-16 Selecting a gadget border to change
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2 Drag the border and drop it at a new position to resize the gadget, as shown in
Figure 1-17.

Text Gadget 1

Sample Text

Figure 1-17 Changing the size of a gadget
3 The gadget resizes to the new dimension, as shown in Figure 1-18.

Text Gadget1

Sample Text

Figure 1-18 Displaying the new gadget dimensions

Formatting a gadget

Gadget formatting options are available in the general properties of a gadget. To
reach the general properties of a gadget, choose Edit. Then, choose General.

Figure 1-19 shows the general gadget properties of a column chart gadget. Each
gadget type includes additional formatting options, depending on the content of
the gadget.

Chart Builder
General Type Data Filter Format
[#] show Header Column Chart- Data Model Font

Show Menu leon
Show Border

Enable Scroll bar

Auto Refresh

« Title Alignment

(® Left Center Right

Cancel m

Figure 1-19 Navigating to a dashboard file
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You can personalize gadgets with the following formatting options:

Auto Refresh, to refresh the gadget at a selected interval

Dimensions, to set the width and height of the gadget after it is added to the
dashboard

Enable Scroll Bar, to display a scrollbar if the gadget is too small for the
content it displays

Font, to select a font for the gadget title

Gadget Title, to customize the name of the gadget
Show Border, to display the gadget border

Show Header, to display the header

Show Menu Icon, to display a gadget’s editing icon

Show Toolbar, to display a toolbar for a cross tab, parameter, report, or table
gadget

Title Alignment, to set the alignment of the gadget title

Testing dashboard content

|§| After adding the gadgets you require, it is important to verify that the dashboard
meets your expectations. In the dashboard editor you can choose View>Run to
open the dashboard in a read-only mode.

The following considerations assist in optimizing a dashboard:

Avoid long queries when on-demand data is not required by using data object
store files instead of data object design files. Object store files are cached in the
BIRT iHub, enabling multiple users to quickly access data.

Avoid delays in rendering BIRT content by using BIRT report document files
in place of BIRT report design files when possible. This avoids the additional
time necessary for data population of a report design file.

If you are showing only selected parts of a BIRT design file, consider using a
BIRT library. A BIRT design file renders every item in the file, even if only part
of the file is being used, such as content displayed in a Reportlet gadget. A
BIRT library only renders the requested content.

Activate dashboard auto refresh only when necessary to monitor changing
data.

If you display data selection gadgets, such as a list, consider using data objects
with optimized indexes for quick population of the gadget.

Consider building data cubes to aggregate data before the data is displayed.
For example, a table gadget that aggregates values requires the browser to
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load all values before it can calculate the aggregate values. If a cross tab was
used to display a data cube of the same data, there is less network traffic and
less processing done by the web browser.
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